问题

环境:CentOS Linux release 7.3.1611 (Core)
yum源:拉去阿里云仓库后自建源
情况说明:使用命令 yum -y install python36 python36-devel 安装 python3 时出现如下报错。

...
Error: Package: python3-libs-3.6.8-10.el7.x86_64 (akiya-mirror)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
2:postfix-2.10.1-6.el7.x86_64 has missing requires of libmysqlclient.so.18()(64bit)
2:postfix-2.10.1-6.el7.x86_64 has missing requires of libmysqlclient.so.18(libmysqlclient_18)(64bit)

解决方法

缺少 Percona-XtraDB-Cluster-shared-55-5.5.37-25.10.756.el6.x86_64.rpm 这个包
下载并安装相关包

# wget http://www.percona.com/redir/downloads/Percona-XtraDB-Cluster/5.5.37-25.10/RPM/rhel6/x86_64/Percona-XtraDB-Cluster-shared-55-5.5.37-25.10.756.el6.x86_64.rpm
# yum -y install Percona-XtraDB-Cluster-shared-55-5.5.37-25.10.756.el6.x86_64.rpm

标题:centos安装软件报错-libmysqlclient.so.18()(64bit)
作者:akiya789
地址:https://little-star.love/articles/2020/03/02/1583130461442.html

添加新评论